Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - BOBLAN

Pages: [1]
1
Singles / Re: B31 Speedo in tank model
« on: 27 June, 2018, 09:47:47 »
Many thanks Julian and Glenn

The parts you have both described seem to be right for the bike, and now I know what they look like, I can keep an eye out forany that might turn up,  as they don't seem to be remade by any of the usual BSA suppliers. I'll also keep a copy of the pictures and parts pages for future reference!


2
Singles / B31 Speedo in tank model
« on: 26 June, 2018, 11:06:18 »
Can anyone tell me how the chronometric speedo should be fixed into the petrol tank? There is no scope for any fixings as the cavity in the tank is inaccessible once the speedo is inserted.

When I pushed mine out, it had just been wedged in with a load of sticky tape wrapped around the unit to make it a tight fit. Perhaps it needs some form of rubber sleeve or grommet? And can anyone tell me if and where these might be available?

If I cannot find out how the original fixing was done, I know that I can just use the 'sticky tape' solution again, but it would be nice to get it right if possible.

Thanks
Bob
 



3
Singles / Number Plates
« on: 30 June, 2017, 15:29:51 »
I have just had my 1946 B31 re-registered by DVLA with an age related number, and I now have an authorisation certificate for getting some new plates made up. Can anyone tell me if the 'stick on' numbers and letters are still legal, or do I have to have the embossed 'silver on black' aluminium types?

Thanks
Bob

4
Singles / Re: B31 Oil return
« on: 09 February, 2017, 17:55:02 »
Many thanks for all the replies, I did as each suggested and got a  result! So yes, I must basically remember to prime the pump next time...

Even got the engine running for a few minutes, but need to now stop the petrol pouring out of the carb...

Thanks again
Bob

5
Singles / B31 Oil return
« on: 08 February, 2017, 12:46:08 »
Hi all

I am in the process of recommissioning a 1946 B31, which has been off the road for the last 25 years. I understand that the engine was rebuilt prior to it being stored, so I was hoping that all is well with it. I am currently changing all the oils and would appreciate any help with the following query:

I have emptied the old engine oil from the tank, cleaned it out and replaced the filter which was damaged. I have taken the sump bolt out to empty any old oil, and removed the bottom cover plate to clean the gauze filter. I have also checked that pressure ball valve is free of its seat.

On refilling the oil tank and removing the spark plug, I was hoping that I would see oil returning to the tank when kicking the engine over fairly fast. However, I cannot see any movement in the oil, so I am worried that the oil may not be circulating? Or perhaps it will only return when the engine is actually running?

I would appreciate any thoughts.
Thanks
Bob 

Pages: [1]