Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Happyhenry

Pages: [1]
1
Singles / Re: B32 - Heavyweight Gearbox Speedo Drive
« on: 30 April, 2020, 16:55:42 »
Thanks Jim,

I've plenty of thin shim stock, so I'll give that a go before trying to decontaminate the cable end sufficient to solder it.

Henry

2
Singles / B32 - Heavyweight Gearbox Speedo Drive
« on: 30 April, 2020, 16:19:47 »
Hello all,

I have a 1949 rigid B32 which has an M-Type heavyweight gearbox on which the speedo drive is mounted top-rear.

Risking life and limb by running the bike in gear on the bench I can see that the inner spindle rotates, so drive assumed OK.
Attaching the cable to a battery screwdriver I can determine that the speedo works (in the same rotation as the gearbox drive).
Connect the cable to the gearbox and the speedo doesn't work.

There seems to be a fairly long tail on the cable, but peering in with a torch I am concerned that the gearbox spindle is worn internally and not gripping the cable.
What is the best solution? I'm currently thinking of building up the cable end with solder and filing back to fit.
Must be quite a common problem. Any suggestions welcomed.
HH

3
Twins / Re: A7 Longstroke - Timing Cover
« on: 27 March, 2020, 22:01:51 »
Answer:

Found the answer. I think. There was an early case with a flat bottom and from about 1947/8 they had an extra fixing bottom-centre. The 'cooking models' were plain covers and the Star Twin had the piled arms engraved on it.

I ask because I have a 1949 A7 with a plan cover, a spare plain cover and a spare standard engine which has a piled arms cover.

H

4
Twins / A7 Longstroke - Timing Cover
« on: 25 March, 2020, 22:05:39 »
Question:

When did the piled arms start appearing on the timing chest cover of the A7 longstroke?

Was it only on the Star Twin, or did the 'cooking model' have it at some point?

Thanks

5
Which BSA do you ride? / Re: A7 Longstroke
« on: 21 August, 2019, 18:59:34 »
That's nice.   Did you get home once the mag cooled down ?

Called the AA - and guess what? They arrived about an hour and a half later and it started, despite me having tried it every 10 minutes up to that point. Chap had a folding trailer in the back of the van so he gave me a ride home rather than me risking doing it in several stages.

Now all running fine after a condensectomy and the fitting of a Brightspark condensor. Although I have since fitted a fully rebuilt spare magneto. Otherwise it's a very pleasant ride. The engine is, I think, on the standard 6:1 pistons and it pulls very well since I put it on solo gearing.

It looks better in the photo than in real life. It's an un-restored survivor having obviously been maintained on a budget (remould quality tyres when I got it) and having had a chair on it for decades. I like them like that - there are plenty of shiny bikes about.

6
Which BSA do you ride? / A7 Longstroke
« on: 20 August, 2019, 21:48:48 »
Here's one of mine - recently sparkless on the Mendips.
Hot old capacitor - now fixed thanks to Brightspark Magnetos...and some keyhole surgery.

Pages: [1]