BSA Owners' Club Forum

The BSA Workshop => Singles => Topic started by: Phil C on 26 February, 2018, 15:48:34

Title: No spark
Post by: Phil C on 26 February, 2018, 15:48:34
Looking to investigate the fact that my "new" 1965 B40F won't run without a bit of choke and yet has a black sooty spark plug, I thought I'd start by checking the timing, before moving on to air filter and carb. So, I've fitted a new set of points plus new backing plate and new condenser, and set the timing. I tried to start it this afternoon, and found I now have no spark at the plug. I've tried another plug. The points are opening and closing, and there is no spark at the points.  Gaps at points and plug are okay. Also front light won't work, although brake light and horn do. I have a loose wire hanging near the carb but don't know what it is or what it might connect to (maybe an accessory fitted in the past?) Any suggestions please as to why there's no spark at the plug?  Phil (novice)

PS I am realising, in the early days of my new retirement hobby of classic bike maintenance, that nothing is simple!
Title: Re: No spark
Post by: AWJDThumper on 26 February, 2018, 17:19:41
If it's a black and white wire then it's the one which connects the coil's +ve terminal to the points. To check the coil circuit you need to verify that -6V is getting to the coil's -ve terminal. If you disconnect the black and white wire from the coil, you should find it connects to earth every time the points close by using an Ohm metre of battery and bub. To test the coil, you will need an Ohm metre which should give 2-3 Ohms between the +ve and -ve terminals and several thousand Ohms when you connect between either of these terminals and the HT output.
Title: Re: No spark
Post by: Phil C on 26 February, 2018, 19:18:17
Thanks for this. However, I've just checked the points gap again (must get a heater in my little shed), and it was a bit too big, so I reset it to .015". Lo and behold, I then got a spark at the plug every time I kicked it over. So that's good. And so I also know the loose wire is not from the coil. The wire is brown, about a foot long at the most, and comes from the battery. I don't see any other connections nearby that it could have come off. Maybe I need to take the seat off and have a look around? To take the seat off, I guess I undo the bolt at the front of it, and then is it the two bolts where the shocks are fixed? Hopefully it's not the two under the seat which look very hard to get at?    Phil(novice).
Title: Re: No spark
Post by: AWJDThumper on 27 February, 2018, 07:03:57
The only brown wire I can see from the wiring diagram is the one to the stop light switch and then to the stop light. If conventionally mounted, the seat has a large U-shaped bracket attached towards the rear which then bolts to the bolts going through the top of the rear shocks. To remove the seat, simply undo the nuts on the shock absorber top bolts and the seat and bracket should pull away upwards. The front of the seat simply slots into the frame just behind the tank.
Title: Re: No spark
Post by: Phil C on 27 February, 2018, 09:11:49
Thanks. So there shouldn't be a bolt to loosen at the front?
Title: Re: No spark
Post by: AWJDThumper on 27 February, 2018, 09:31:05
No. The seat has a slotted bracket at the front which slots into the thin cross bar at the front top of the rear sub-frame.
Title: Re: No spark
Post by: Pauldemob on 27 February, 2018, 14:07:55
Hi you will need to undo the two nuts right at the back under the seat. Pull the seat up off the frame and then slide it back away from tank. Take care replacing not to catch any wire at the front. Wd b40 are different in many things from civilian ones. It should also be 12volt. My is .   great bikes