Author Topic: c15 running rich  (Read 411 times)

0 Members and 1 Guest are viewing this topic.

OLIVER

  • Star
  • *
  • Posts: 13
    • View Profile
c15 running rich
« on: 14 May, 2017, 23:37:48 »
hi can anyone out there help
my c15 starts first or second kick cold  .but as it warms up .it runs rich black smoke
and barely idles  ive lowered the needle to max
im running points still ..there ok .charging ok 7.5 volts
after recent rebuild resto .
any clues guys . maybe  jet sizes that i could check!
thanx ian

TIGER

  • Star
  • *
  • Posts: 42
    • View Profile
Re: c15 running rich
« Reply #1 on: 15 May, 2017, 05:18:52 »
Hi Oliver
           I have just finished a C15 myself.
           With lots of help from the BSA forum.
            There are many more experienced people to help but you could start by
            checking the float and level in the chamber.
             Have you the normal 375 carb ?
Regards
           Tim

JulianS

  • Empire Star
  • *****
  • Posts: 558
  • A10
    • View Profile
Re: c15 running rich
« Reply #2 on: 15 May, 2017, 10:05:16 »
hi can anyone out there help
my c15 starts first or second kick cold  .but as it warms up .it runs rich black smoke
and barely idles  ive lowered the needle to max
im running points still ..there ok .charging ok 7.5 volts
after recent rebuild resto .
any clues guys . maybe  jet sizes that i could check!
thanx ian

If you bike is the home market C15 Star and not an SS80 or competition model then it should be fitted with a type 375 monobloc with 7/8 inch bore.

If it is an original carb and not  modern production it is probably marked 375/34 on the mounting flange.

It shold be fitted with ;

140 main jet

105 needle jet

25 pilot jet

4 throttle valve

Needle fitted in position 3.

The needle jet could be worn or someone may have fitted the more common 106 size.

Or the carb could be wrongly assembled

Check the joint between the float needle seating and carb body.

If the carb has a recess as the photo then there should be fibre washer between body and seating.

If the body is flat no recess then the joint should be metal to metal. Sometime a fibre washer is wrongly fitted in this joint. It raises the float level and can cause flooding and rich running.



OLIVER

  • Star
  • *
  • Posts: 13
    • View Profile
Re: c15 running rich
« Reply #3 on: 16 May, 2017, 19:56:18 »
thanx julian i will check them few things out and let you know

OLIVER

  • Star
  • *
  • Posts: 13
    • View Profile
Re: c15 running rich
« Reply #4 on: 22 May, 2017, 20:14:44 »
many thanks julian .with your help
i found the problem it had a washer on the bottom .as you said
took it out and it now idles ok ..all the other points checked out ok ie jet sizes
im one happy bunny..and its finished finally
again thankyou .ian.. :-*