Author Topic: C15 Electrics  (Read 612 times)

0 Members and 1 Guest are viewing this topic.

Calvin

  • Star
  • *
  • Posts: 29
    • View Profile
C15 Electrics
« on: 08 April, 2017, 16:43:18 »
Hi

Re building a c15.
New Lucas loom.
All lights work , horn works, stop light works all earths are very good.
I am trying to fit a boyer ignition kit 0059 I have followed the instructions but can not get a spark and I am getting close to giving up.
I will admit I don't have a great knowledge of these things so any advice would be very welcome

DEAN SOUTHALL

  • Royal Star
  • ***
  • Posts: 154
    • View Profile
Re: C15 Electrics
« Reply #1 on: 08 April, 2017, 19:59:40 »
How frustrating. Hang in there mate. I've been there plenty of times and one day as you are enjoying the ride this will be a distant memory.
Sorry if these are obvious but are you sure you are not getting a spark? I thought mine had packed up and it was just that the spark was such a light colour I could not see it in daylight! Secondly, remember that Boyer does need a good battery voltage. Check that it hasn't dropped while you've been testing etc.

Bess

  • Silver Star
  • ****
  • Posts: 251
    • View Profile
Re: C15 Electrics
« Reply #2 on: 09 April, 2017, 09:12:52 »
Hi Calvin,
 
Have you tried this website for ideas?

http://www.boyerbransden.com/faultfinding.html

Best wishes...


DEAN SOUTHALL

  • Royal Star
  • ***
  • Posts: 154
    • View Profile
Re: C15 Electrics
« Reply #3 on: 09 April, 2017, 15:09:36 »
Lets hope Old Biker doesn't look on this thread ;)

Calvin

  • Star
  • *
  • Posts: 29
    • View Profile
Re: C15 Electrics
« Reply #4 on: 09 April, 2017, 18:38:16 »
Thanks for your replies.
Lets hope there is some old British biker reading this thread and they can come and rescue me.
We all have learn sometimes and even those old guys had to learn.

Bess

  • Silver Star
  • ****
  • Posts: 251
    • View Profile
Re: C15 Electrics
« Reply #5 on: 09 April, 2017, 18:43:09 »
Well lets hope us younger ones get you back riding out on these sunny days we are having. Dartmoor was superb today............

TTJOHN

  • Royal Star
  • ***
  • Posts: 128
    • View Profile
Re: C15 Electrics
« Reply #6 on: 10 April, 2017, 08:23:30 »
Calvin.
You should not have any problem, if as you say you fitted new loom and there should be no need to fit a Boyer Bransden kit, Have you checked the coil to make sure your getting power to  it on the switch side and the contact breaker side, also to make sure you have the correct gap on the points and that you have the timing? after checking all this, I would make sure your not 180 degrees out with the distributor.

TTJohn

DEAN SOUTHALL

  • Royal Star
  • ***
  • Posts: 154
    • View Profile
Re: C15 Electrics
« Reply #7 on: 10 April, 2017, 12:27:21 »
Calvin,
If all else fails I'm only the other side of town.

Calvin

  • Star
  • *
  • Posts: 29
    • View Profile
Re: C15 Electrics
« Reply #8 on: 10 April, 2017, 14:20:33 »
Thanks Dean.
Update I now have a spark after going back over the connections .
I had plugged a wire into a dormant wire.