Author Topic: C15 No Spark  (Read 559 times)

0 Members and 1 Guest are viewing this topic.

Sage29

  • Star
  • *
  • Posts: 4
    • View Profile
C15 No Spark
« on: 17 November, 2017, 15:53:12 »
Hi I have a 1961 C15 which hasn't started for over 30 years, I have purchased a new battery,coil,points,condenser, HT lead, and spark plug. I have taken a wire from the - on the battery to the - on the coil and also from the + on the coil to the points, I've also cleaned up the earth connections and taken an earth wire from the engine to the frame but when I kick the bike over I still get no spark, I don't know what else I can do as I've bypassed everything, any suggestions would be greatly appreciated,thanks

TIGERJ

  • Blue Star
  • **
  • Posts: 74
    • View Profile
Re: C15 No Spark
« Reply #1 on: 19 November, 2017, 17:55:38 »
Hello
       I just rebuilt a c15
       Had a similar problem
       You could check that the insulating washer is fitted on the points "peg"
       If this is no help I would be willing to have a look
       Are you anywhere near Staffordshire?
Regards
       Tim

TIGERJ

  • Blue Star
  • **
  • Posts: 74
    • View Profile
Re: C15 No Spark
« Reply #2 on: 22 November, 2017, 01:44:54 »
Just wondering did you get the C15 running ?

Sage29

  • Star
  • *
  • Posts: 4
    • View Profile
Re: C15 No Spark
« Reply #3 on: 22 November, 2017, 19:43:45 »
Hi, not running but I have managed to get a spark, I added an earth lead from the coil to the engine and also found some perished wires coming from the alternator which I wrapped insulation tape around as thought they may have been dragging it down, I'm planning to put a teaspoon of petrol down the barrel tonight to see if she will fire over.
Thanks for your help.

Ade

A10 JWO

  • Royal Star
  • ***
  • Posts: 149
    • View Profile
Re: C15 No Spark
« Reply #4 on: 23 November, 2017, 16:22:50 »
Have a fire  extinguisher handy. Good luck they are a solid little engine. Make sure you have some oil in there.

ANDY HIGHAM

  • Star
  • *
  • Posts: 47
    • View Profile
Re: C15 No Spark
« Reply #5 on: 24 November, 2017, 15:31:25 »
Hi, not running but I have managed to get a spark, I added an earth lead from the coil to the engine and also found some perished wires coming from the alternator which I wrapped insulation tape around as thought they may have been dragging it down, I'm planning to put a teaspoon of petrol down the barrel tonight to see if she will fire over.
Thanks for your help.

Ade

There should be no electrical connection between the coil and earth. The coil circuit from the battery - ignition switch - coil - contact breaker / condensor - earth

TIGERJ

  • Blue Star
  • **
  • Posts: 74
    • View Profile
Re: C15 No Spark
« Reply #6 on: 24 November, 2017, 22:32:40 »
Andy
The ignition coil body needs to be earthed (connected to frame) to complete the HT circuit.

Sage29

  • Star
  • *
  • Posts: 4
    • View Profile
Re: C15 No Spark
« Reply #7 on: 25 November, 2017, 10:13:42 »
Wouldn't start even with some fuel down the barrel, lots of compression there so I'm guess I have a timing issue to look at

TIGERJ

  • Blue Star
  • **
  • Posts: 74
    • View Profile
Re: C15 No Spark
« Reply #8 on: 25 November, 2017, 10:28:07 »
Try some easystart through the carburettor.

ANDY HIGHAM

  • Star
  • *
  • Posts: 47
    • View Profile
Re: C15 No Spark
« Reply #9 on: 25 November, 2017, 11:13:56 »
Andy
The ignition coil body needs to be earthed (connected to frame) to complete the HT circuit.

No it doesn't
http://gooddy.org/wp-content/uploads/2017/07/wiring-diagram-for-ignition-coil-readingrat-net-within-condenser.jpg
« Last Edit: 25 November, 2017, 11:15:28 by ANDY HIGHAM »

TIGERJ

  • Blue Star
  • **
  • Posts: 74
    • View Profile
Re: C15 No Spark
« Reply #10 on: 25 November, 2017, 11:26:00 »
Then how does the HT spark get earthed ?

ANDY HIGHAM

  • Star
  • *
  • Posts: 47
    • View Profile
Re: C15 No Spark
« Reply #11 on: 25 November, 2017, 11:57:00 »
Via the condensor

TIGERJ

  • Blue Star
  • **
  • Posts: 74
    • View Profile
Re: C15 No Spark
« Reply #12 on: 25 November, 2017, 12:36:24 »
Condenser is on the LT circuit.
Never touches the HT.

JulianS

  • Empire Star
  • *****
  • Posts: 630
  • A10
    • View Profile
Re: C15 No Spark
« Reply #13 on: 25 November, 2017, 13:12:45 »
The coil body does not form part of the ignition circuit, it is just a container for the insulated primary and secondary windings and their core.

Should either winding be earthed through the body then there would be no spark.

To operated, the coil primary winding has battery voltage applied to one side and, when points are closed, the winding is earthed and a magnetic field builds up around core. When the points open the field collapses and a high voltage is induced into the secondary winding which goes via the plug gap (spark) to earth.