Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - shill

Pages: [1]
1
Twins / BSA A10 Super Rocket rewire
« on: 14 March, 2017, 16:58:17 »
Hi, I have a 1958 Super Rocket. I took it to someone who was recommended by my local classic bike garage (they sadly only wanted to deal with Triumphs). Anyway I took it in because the mag needed reconditioning. Everything appeared to be fine, including the amp meter. I got him to do a few other bits as I didn't have much time. He told me he did a lot of rewiring, but I didn't think anything of it. I asked him to have a look at the light in the speedo as it didn't work.

Everything appeared to be fine, all lights were working. I was riding it home and I noticed the amp meter wasn't indicating charge only discharge. I have taken the seat off today and the negative lead is earthed which for a start I believe is wrong? Shouldn't it be positively earthed? I am not sure how this would change anything. Would that explain why that battery is only reading 4 volts and why It won't charge?

I can't understand what he's done or why the lights are not working. There are a couple of leads which have loose but none of the leads match the colours in the Haynes manual. Also some leads appear to be going to the wrong  switch terminals ect. My next question. In the Haynes manual there appears to be 7 terminals on the switch but there is only 6 on mine, so effectively the number (2) which is missing in the Haynes manual diagram. But this appears to be missing from other replicators I've seen on the market. So what is the correct way to wire up that switch? As in the Haynes manual you need to use the number 2 terminal which isn't there.

Please help,
Many thanks, Stephen.

Pages: [1]