BSA Owners' Club Forum

The BSA Workshop => Twins => Topic started by: david c on 14 January, 2018, 19:55:13

Title: wassell power module on A65
Post by: david c on 14 January, 2018, 19:55:13
hi, i thought the rectifier on my A65 was faulty so i got a wassell power module to replace it but now it does not seem to be charging. i used a multimeter to check connections and they were fine but when i checked the red and black leads,  pos and neg on the unit  for continuity it showed they are connected to each other , is that right?  any ideas would be appreciated
Title: Re: wassell power module on A65
Post by: AWJDThumper on 14 January, 2018, 20:04:43
In general, you can't really test a rectifier/regulator unit - provided it is connected up correctly, it will either work or it won't. The red and black wire should definitely not have zero resistance between them!
Title: Re: wassell power module on A65
Post by: david c on 20 January, 2018, 16:36:29
thanks for the reply, i will try another unit
Title: Re: wassell power module on A65
Post by: AWJDThumper on 20 January, 2018, 17:07:11
Did you check the original rectifier with an multi-meter? Since it's basically a network of 4 diodes, it's very easy to check that the diodes are ok or not.
Title: Re: wassell power module on A65
Post by: david c on 24 January, 2018, 13:08:12
hi, how do you check original rectifer, also where is the best place to check if its charging. its showing nothing on ameter, where with the original rectifier it used to always showed it was charging!
Title: Re: wassell power module on A65
Post by: AWJDThumper on 24 January, 2018, 18:27:58
The ammeter is between the rectifier and battery and so should show any charging current.

The rectifier is very easy to test with an ammeter set on measuring resistance. As per wiring diagram, there are 4 diodes to test in turn. To test each one, you need to measure its resistance with the ammeter leads connected one way round and then measure again with the leads switched the other way round. If the diode is working correctly, it should give a low resistance in one direction and a high resistance when connected the other way round. If you get a high resistance in both directions, it means the diode has blown. You need all four diodes to be working.

Also, did you disconnect the Zener diode when you switched to the power module. To roughly test the Zener, just repeat the test you did with the rectifier diodes.
Title: Re: wassell power module on A65
Post by: JulianS on 24 January, 2018, 19:06:54
A couple of tests from the Lucas manual. Dont worry about the 1 ohm resistance, you will get an idea if the alternator is charging without it.
Title: Re: wassell power module on A65
Post by: Caulky on 29 January, 2018, 10:26:54
See this thread about measuring diode resistance:
http://www.bsaownersclub.co.uk/bsaoc_forum/index.php?topic=2397.0
Title: Re: wassell power module on A65
Post by: david c on 31 January, 2018, 22:23:38
hi and thanks for all your replies and help over the last few weeks but i have to admit defeat with this! does anyone know of an auto electrician in worcestershire  area thats happy to work on early a65?
Title: Re: wassell power module on A65
Post by: AWJDThumper on 01 February, 2018, 07:22:21
Electrics can appear a bit daunting at times but are basically relatively simple in their design. If you have a multimeter and a wiring diagram, problems with them are not that difficult to diagnose with a bit of help from others.

So please let us know how far you got with the tests - were you in a position to carry out the tests on the original rectifier and, if so, what were the results?
Title: Re: wassell power module on A65
Post by: DEE on 01 February, 2018, 09:01:35
Maybe you could visit the Wyre Forest branch of the BSA Owners club and ask for assistance from members there. If you go to the branch listing on the website you will find where and when they meet.
Title: Re: wassell power module on A65
Post by: david c on 03 February, 2018, 17:04:57
hi, checked the rectifier with bulb system and it was fine, i am not familiar with multimeter! i have had the bike for 30 years and fitted electronic ignition years ago and have had no problems with wiring at all, i dont think the alternator is charging, set the multimeter and it showed no reading at all. is there another way to check output of alternator?  thanks again for all your replies
Title: Re: wassell power module on A65
Post by: JulianS on 03 February, 2018, 17:55:28
Simple test to show if alternator is working - disconnect alternator at the connectors. With engine running connect a 12 volt headlamp bulb between any 2 alternator output wires (you dont say if your stator is 2 or 3 wire)  and bulb should light, rev engine bulb should glow brighter. It will not show whether it is fully working, for that go back to my earlier post.
Title: Re: wassell power module on A65
Post by: david c on 03 February, 2018, 18:43:15
great, thanks for that, i will try that tomorrow! its a 2 wire alternator on a 1962 a65, i need a wiring diagram for early model, it started as a 6 volt but converted before i got it
Title: Re: wassell power module on A65
Post by: JulianS on 03 February, 2018, 19:05:33
A early wiring diagram may not help, that would be for a 3 wire stator use at the time.

The 12 volt diagram from the 1962-65 workshop manual shown below which may be a start.
Title: Re: wassell power module on A65
Post by: david c on 04 February, 2018, 12:25:06
hi, i tried alternator test and it is not working, what can go wrong with them, is it best to change alternator and stator?